summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-27 11:28:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-27 11:28:38 +0100
commit5f1e31094d390a85bb91e8df1efbcb2dd2e39cf4 (patch)
tree8c62d70865facd7956c931d377802666a9b80339
parent2a509880d4c543013c49fc45bbc63dd49b8d4a81 (diff)
downloadguix-5f1e31094d390a85bb91e8df1efbcb2dd2e39cf4.tar.gz
gnu: trim-galore: Fix test for Python.
* gnu/packages/bioinformatics.scm (trim-galore)[arguments]: Replace
"configure" phase to skip ill-advised test for Python.
-rw-r--r--gnu/packages/bioinformatics.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1f2991418a..3f94ef54cd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10896,7 +10896,15 @@ with narrow binding events such as transcription factor ChIP-seq.")
      `(#:tests? #f                      ; no tests
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
+         (replace 'configure
+           (lambda _
+             ;; Trim Galore tries to figure out what version of Python
+             ;; cutadapt is using by looking at the shebang.  Of course that
+             ;; doesn't work, because cutadapt is wrapped in a shell script.
+             (substitute* "trim_galore"
+               (("my \\$python_return.*")
+                "my $python_return = \"Python 3.999\";\n"))
+             #t))
          (delete 'build)
          (add-after 'unpack 'hardcode-tool-references
            (lambda* (#:key inputs #:allow-other-keys)