summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2020-10-23 22:53:41 +0200
committerJelle Licht <jlicht@fsfe.org>2020-12-04 12:49:02 +0100
commit6fc283a05aae933b274a6624d28e13fe95ad3d40 (patch)
tree282f8153813f5c4d30838c50b9e0808b054af22f
parentbf2365b657914efba9dbcf3a43652729c41fb121 (diff)
downloadguix-6fc283a05aae933b274a6624d28e13fe95ad3d40.tar.gz
gnu: node: Add node-binary-search-bootstrap.
* gnu/packages/node.scm (node-binary-search-bootstrap): New package.
-rw-r--r--gnu/packages/node.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 7dc6317d1d..c85e10454a 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -289,6 +289,38 @@ devices.")
 milliseconds.")
     (license license:expat)))
 
+(define-public node-binary-search-bootstrap
+  (package
+    (name "node-binary-search")
+    (version "1.3.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/darkskyapp/binary-search.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1xr2msdc143cd3xwgq7n3rhzy7j8wrnaidxl0r6l6b6g3mpbpjig"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:node ,node-bootstrap
+       #:tests? #f
+       #:phases
+       (modify-phases
+           %standard-phases
+         (delete 'configure)
+         (delete 'build))))
+    (home-page
+     "https://github.com/darkskyapp/binary-search#readme")
+    (properties '((hidden? . #t)))
+    (synopsis
+     "Tiny binary search function with comparators")
+    (description
+     "This package is a binary search function for @code{Node.js}.")
+    (license license:cc0)))
+
 (define-public libnode
   (package
     (inherit node)