summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-05 23:14:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-06 00:14:28 +0200
commit8128189976ad0fef5065bb3f1b552273d8990759 (patch)
tree7db16d78b6b1d003e3f0b141d02c8de01d5d0bdf
parent993912905d6e9130fa4b543b7b45a07113785c8b (diff)
downloadguix-8128189976ad0fef5065bb3f1b552273d8990759.tar.gz
gnu: Add r-rcpphnsw.
* gnu/packages/cran.scm (r-rcpphnsw): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 29d6e336e3..10e5e8b0d5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8584,6 +8584,28 @@ This package provides an R interface.")
     ;; GPLv2+.
     (license (list license:gpl2+ license:asl2.0))))
 
+(define-public r-rcpphnsw
+  (package
+    (name "r-rcpphnsw")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppHNSW" version))
+       (sha256
+        (base32
+         "158a069n42pbnjrlmvqsr6bm2cfp9hxpnk3nhp3dwi9qjlq4r9bm"))))
+    (properties `((upstream-name . "RcppHNSW")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/RcppHNSW/")
+    (synopsis "Rcpp bindings for hnswlib, a library for approximate nearest neighbors")
+    (description
+     "Hnswlib is a C++ library for approximate nearest neighbors.  This
+package provides a minimal R interface by relying on the Rcpp package.")
+    ;; hnswlib is released under Version 2.0 of the Apache License.
+    (license (list license:gpl3 license:asl2.0))))
+
 (define-public r-ncdf4
   (package
     (name "r-ncdf4")