summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:14 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:59 -0400
commit8ea94489fd954960acb2edc269b7cb88a3a38bae (patch)
tree4928f67dd844d0166f86f57a54d313152ac14059
parent7e06c4aa98a3d240c8e8847e825c1a2f780e1fbe (diff)
downloadguix-8ea94489fd954960acb2edc269b7cb88a3a38bae.tar.gz
gnu: Add ghc-chell.
* gnu/packages/haskell.scm (ghc-chell): New variables.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 51cfa74a21..39a231266d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7250,4 +7250,33 @@ spirit to POSIX shells.  Shelly is originally forked  from the Shellish package.
 easily work with command-line options.")
     (license license:expat)))
 
+(define-public ghc-chell
+  (package
+    (name "ghc-chell")
+    (version "0.4.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/chell/chell-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0lb95abzxl4a87nfqxsxpb3a39pd52cci43hcvj8615hyhqvs2jz"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-options-bootstrap" ,ghc-options-bootstrap)
+       ("ghc-patience" ,ghc-patience)
+       ("ghc-random" ,ghc-random)
+       ("ghc-text" ,ghc-text)
+       ("ghc-ansi-terminal" ,ghc-ansi-terminal)))
+    (home-page "https://john-millikin.com/software/chell/")
+    (synopsis "Simple and intuitive library for automated testing")
+    (description
+     "Chell is a simple and intuitive library for automated testing.
+It natively supports assertion-based testing, and can use companion
+libraries such as @code{chell-quickcheck} to support more complex
+testing strategies.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here