summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2020-10-23 22:20:30 +0200
committerJelle Licht <jlicht@fsfe.org>2020-12-04 12:49:01 +0100
commit9498ef001fcc3029c63f302a177b723dbc7b523f (patch)
treeb85b230ebf2636180100f880eba1d7c434372365
parentd0433fd5ed5104f0fd22da3297293eded93a38a3 (diff)
downloadguix-9498ef001fcc3029c63f302a177b723dbc7b523f.tar.gz
gnu: Add libuv-node
* gnu/packages/libevent.scm (libuv-node): New variable.
-rw-r--r--gnu/packages/libevent.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index dab574a155..dfbf7067bf 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -133,6 +133,22 @@ resolution, asynchronous file system operations, and threading primitives.")
     ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
     (license (list expat cc-by4.0))))
 
+(define-public libuv-node
+  ;; When upgrading Node, also upgrade this. Get the version from
+  ;; https://github.com/nodejs/node/blob/master/deps/uv/include/uv/version.h
+  (package
+    (inherit libuv)
+    (name "libuv-node")
+    (version "1.40.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://dist.libuv.org/dist/v" version
+                                  "/libuv-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "1551k3ab27vbg9517l9b4iqbramwxdkwgpf53knas05cbfwhvab1"))))))
+
+
 (define-public perl-anyevent
   (package
     (name "perl-anyevent")