summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-12-03 12:11:00 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-12-03 12:11:00 +0100
commit9cf531f57786c858c34c11a08b0ad16e2f26b27b (patch)
treed2f7759874ec6f3653d1dc634875dd8b127d70a0
parentc050bef5cf79301d15f0bf8fb09feab085d9ff61 (diff)
downloadguix-9cf531f57786c858c34c11a08b0ad16e2f26b27b.tar.gz
images: Add novena-image-type, novena-barebones-raw-image, novena-barebones-os.
* gnu/system/images/novena.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/system/images/novena.scm67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9f46ed2e0d..28ad119846 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -652,6 +652,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/system/vm.scm				\
 						\
   %D%/system/images/hurd.scm			\
+  %D%/system/images/novena.scm			\
   %D%/system/images/pine64.scm			\
   %D%/system/images/pinebook-pro.scm		\
 						\
diff --git a/gnu/system/images/novena.scm b/gnu/system/images/novena.scm
new file mode 100644
index 0000000000..335074e3b7
--- /dev/null
+++ b/gnu/system/images/novena.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu system images novena)
+  #:use-module (gnu bootloader)
+  #:use-module (gnu bootloader u-boot)
+  #:use-module (gnu image)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu services)
+  #:use-module (gnu services base)
+  #:use-module (gnu system)
+  #:use-module (gnu system file-systems)
+  #:use-module (gnu system image)
+  #:use-module (srfi srfi-26)
+  #:export (novena-barebones-os
+            novena-image-type
+            novena-barebones-raw-image))
+
+(define novena-barebones-os
+  (operating-system
+    (host-name "vignemale")
+    (timezone "Europe/Paris")
+    (locale "en_US.utf8")
+    (bootloader (bootloader-configuration
+                 (bootloader u-boot-novena-bootloader)
+                 (target "/dev/vda")))
+    (initrd-modules '("sdhci-esdhc-imx" "ahci_imx"))
+    ;(kernel linux-libre-arm-generic)
+    (file-systems (cons (file-system
+                          (device (file-system-label "my-root"))
+                          (mount-point "/")
+                          (type "ext4"))
+                        %base-file-systems))
+    (services (cons (service agetty-service-type
+                             (agetty-configuration
+                              (extra-options '("-L")) ; no carrier detect
+                              (baud-rate "115200")
+                              (term "vt100")
+                              (tty "ttymxc1")))
+                    %base-services))))
+
+(define novena-image-type
+  (image-type
+   (name 'novena-raw)
+   (constructor (cut image-with-os arm32-disk-image <>))))
+
+(define novena-barebones-raw-image
+  (image
+   (inherit
+    (os->image novena-barebones-os #:type novena-image-type))
+   (name 'novena-barebones-raw-image)))