summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-24 01:44:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-28 00:01:43 +0200
commit5478ab1ecea15b506c1c286af1aa8ec89f26aa10 (patch)
tree0c5d6c6152af01a12d21442ca023dc6760ee5133
parent697c5846651cbee20538d96446cc48adb8e2462a (diff)
downloadguix-5478ab1ecea15b506c1c286af1aa8ec89f26aa10.tar.gz
gnu: mbpfan: Don't use unstable tarball.
* gnu/packages/linux.scm (mbpfan)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ba0022a8a6..9e279b91e8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4830,13 +4830,14 @@ interface to this kernel feature.")
     (version "2.1.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/dgraziotin/mbpfan/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dgraziotin/mbpfan.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1j44bpwv2zszih3cia9h7i7gb2gbfhzqh0s4kscbl7nplvyk3rlp"))))
+         "1gysq778rkl6dvvj9a1swxcl15wvz0bng5bn4nwq118cl8p8pask"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f                      ; tests ask to be run as root