summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2021-05-09 18:11:21 -0400
committerKei Kebreau <kkebreau@posteo.net>2021-05-09 19:14:04 -0400
commita77340e1cd434f5e328a49a1065247fc54885612 (patch)
treeb37617fa6cca7cb5d743bc61b0070c016847909c
parentff9c881ffee0454fca0212a8f240253c18415d4a (diff)
downloadguix-a77340e1cd434f5e328a49a1065247fc54885612.tar.gz
gnu: retux: Update to 1.5.
* gnu/packages/games.scm (retux): Update to 1.5.
[source]: Download zip archive since a stable tar archive is unavailable.
[native-inputs]: Add unzip.
-rw-r--r--gnu/packages/games.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index efe2c72dad..e340b4aaec 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2086,8 +2086,8 @@ Every puzzle has a complete solution, although there may be more than one.")
    (license license:gpl2+)))
 
 (define-public retux
-  (let ((release "1.4.1")
-        (revision 1))
+  (let ((release "1.5")
+        (revision 0))
     (package
       (name "retux")
       (version (if (zero? revision)
@@ -2099,10 +2099,10 @@ Every puzzle has a complete solution, although there may be more than one.")
                 (uri (string-append "https://github.com/retux-game/retux/"
                                     "releases/download/v"
                                     version "/retux-"
-                                    release "-src.tar.gz"))
+                                    release "-src.zip"))
                 (sha256
                  (base32
-                  "1vrldg2qh2gqfswj7vkpc589ldrrjd903j6cnfdik9zh0jhlq4h2"))))
+                  "1yima7s36hn2kh5h08lczc5iid8jbdxk7x1g5ms6knaznzj7rll3"))))
       (build-system python-build-system)
       (arguments
        `(#:tests? #f                    ; no check target
@@ -2125,6 +2125,8 @@ Every puzzle has a complete solution, although there may be more than one.")
                  (copy-file "retux.py" (string-append bin "/retux"))
                  (copy-recursively "data" data)
                  #t))))))
+      (native-inputs
+       `(("unzip" ,unzip)))
       (inputs
        `(("python-sge-pygame" ,python-sge-pygame)
          ("python-six" ,python-six)