summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-18 14:14:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-18 14:22:26 +0200
commit0f3789477a79a4816ffdc8e1a232543909455d2c (patch)
tree06203ac074d972b06ba62150c8871585ad953605
parentdede052a2cb5f8e35ddb342c6d77b5784f46ed0b (diff)
downloadguix-0f3789477a79a4816ffdc8e1a232543909455d2c.tar.gz
gnu: python2-ipykernel: Split from python-ipykernel.
* gnu/packages/python-xyz.scm (python2-ipykernel): Define without
package-with-python2.
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 28ed440c78..a2abf36cbd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5034,8 +5034,39 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
      "This package provides the IPython kernel for Jupyter.")
     (license license:bsd-3)))
 
+;; Version 5.1.1 and above no longer support Python 2.
 (define-public python2-ipykernel
-  (package-with-python2 python-ipykernel))
+  (package
+    (name "python2-ipykernel")
+    (version "5.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ipykernel" version))
+       (sha256
+        (base32 "0br95qhrd5k65g10djngiy27hs0642301hlf2q142i8djabvzh0g"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (setenv "HOME" "/tmp")
+             (invoke "pytest" "-v")
+             #t)))))
+    (propagated-inputs
+     `(("python2-ipython" ,python2-ipython)
+       ;; imported at runtime during connect
+       ("python2-jupyter-client" ,python2-jupyter-client)))
+    (native-inputs
+     `(("python2-pytest" ,python2-pytest)
+       ("python2-nose" ,python2-nose)))
+    (home-page "https://ipython.org")
+    (synopsis "IPython Kernel for Jupyter")
+    (description
+     "This package provides the IPython kernel for Jupyter.")
+    (license license:bsd-3)))
 
 (define-public python-pari-jupyter
   (package