summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-03-17 21:52:51 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-03-17 21:55:51 +0300
commit19c0cdb9e6271956015232421ef7f63a1ad001ae (patch)
tree436717c0174e05307eb6374c49321dd18a293362
parentde3ed0b4d4e15409fcd5c1679488f34fba44912f (diff)
downloadguix-19c0cdb9e6271956015232421ef7f63a1ad001ae.tar.gz
gnu: tome4: Fix build.
* gnu/packages/games.scm (tome4)[source]: Patch 'src/tgl.h' in snippet.
-rw-r--r--gnu/packages/games.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 360cbe8c1d..74fc452e32 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -37,6 +37,7 @@
 ;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4828,6 +4829,8 @@ Crowther & Woods, its original authors, in 1995.  It has been known as
              (("#elif defined(__FreeBSD__)" line)
               (string-append
                line " || defined(__GNUC__)")))
+           (substitute* '("src/tgl.h")
+             (("#include <GL/glext.h>") ""))
            #t))))
     (build-system gnu-build-system)
     (native-inputs