summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-11-29 20:39:53 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-12-17 22:09:11 +0300
commit1a3e7534d0a02fad1d19173985cf47e1aaa3b956 (patch)
tree31bd700a0b7ce6b1f3a81823f37bab8e58ebc337
parente517161d6b0ee544dab94477c9ffbad59cc1834b (diff)
downloadguix-1a3e7534d0a02fad1d19173985cf47e1aaa3b956.tar.gz
gnu: Add php-with-bcmath.
* gnu/packages/php.scm (php-with-bcmath): New variable.
-rw-r--r--gnu/packages/php.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index dfb9f2db3a..5ffe7c8999 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -48,6 +48,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:))
 
 (define-public php
@@ -348,3 +349,12 @@ systems, web content management systems and web frameworks." )
               license:lgpl2.1+                              ; ext/bcmath/libbcmath
               license:bsd-2                                 ; ext/fileinfo/libmagic
               license:expat))))                             ; ext/date/lib
+
+(define-public php-with-bcmath
+  (package
+    (inherit php)
+    (name "php-with-bcmath")
+    (arguments
+     (substitute-keyword-arguments (package-arguments php)
+       ((#:configure-flags flags)
+        `(cons "--enable-bcmath" ,flags))))))