summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 16:44:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:54 +0200
commit2537a7bf26a01d393822e0618729b929db93e5cb (patch)
treecd18dd4fa2e7c38e3676495dbd26100ed460732e
parent4e6387846b1bcb1df866520a3e65a396a5eb0870 (diff)
downloadguix-2537a7bf26a01d393822e0618729b929db93e5cb.tar.gz
gnu: python-pycodestyle: Update to 2.6.0.
* gnu/packages/python-xyz.scm (python-pycodestyle): Update to 2.6.0.
[arguments]: Replace check phase.
[native-inputs]: Add python-pytest.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ae336c1117..77f1ff72f3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5019,15 +5019,23 @@ a simple netcat replacement with chaining support.")
 (define-public python-pycodestyle
   (package
     (name "python-pycodestyle")
-    (version "2.5.0")
+    (version "2.6.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pycodestyle" version))
        (sha256
         (base32
-         "0v4prb05n21bm8650v0a01k1nyqjdmkrsm3zycfxh2j5k9n962p4"))))
+         "0bhr6ia0hmgx3nhgibc9pmkzhlh1zcqk707i5fbxgs702ll7v2n5"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (home-page "https://pycodestyle.readthedocs.io/")
     (synopsis "Python style guide checker")
     (description "@code{pycodestyle} (formerly pep8) is a tool to check