summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-27 18:02:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-27 18:02:16 +0300
commit35cb1bc527f2ad18db8620650a0d04b16b7eeca7 (patch)
tree7e4e407d969775e9e4c77a6b6e4c6447f1a8cef7
parent3dd310087a883df6eb5ce47ca24fe8fbac15a2d7 (diff)
downloadguix-35cb1bc527f2ad18db8620650a0d04b16b7eeca7.tar.gz
gnu: tabixpp: Build and install shared library and headers.
* gnu/packages/bioinformatics.scm (tabixpp)[arguments]: Adjust custom
'build phase to build shared library. Adjust custom 'install phase to
install libraries and header.
-rw-r--r--gnu/packages/bioinformatics.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a556354438..f7887b50d0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15400,12 +15400,19 @@ mutations from scRNA-Seq data.")
                       (string-append "HTS_LIB=" htslib-ref "/lib/libhts.a")
                       (string-append "INCLUDES= -I" htslib-ref "/include/htslib")
                       "HTS_HEADERS="    ; No need to check for headers here.
-                      (string-append "LIBPATH=-L. -L" htslib-ref "/include")))))
+                      (string-append "LIBPATH=-L. -L" htslib-ref "/include"))
+              (invoke "g++" "-shared" "-o" "libtabixpp.so" "tabix.o" "-lhts")
+              (invoke "ar" "rcs" "libtabixpp.a" "tabix.o"))))
         (replace 'install
           (lambda* (#:key outputs #:allow-other-keys)
-            (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-              (install-file "tabix++" bin))
-            #t)))))
+            (let* ((out (assoc-ref outputs "out"))
+                   (lib (string-append out "/lib"))
+                   (bin (string-append out "/bin")))
+              (install-file "tabix++" bin)
+              (install-file "libtabixpp.so" lib)
+              (install-file "libtabixpp.a" lib)
+              (install-file "tabix.hpp" (string-append out "/include"))
+              #t))))))
    (home-page "https://github.com/ekg/tabixpp")
    (synopsis "C++ wrapper around tabix project")
    (description "This is a C++ wrapper around the Tabix project which abstracts