summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-26 18:09:32 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-26 18:14:39 +0100
commit3d8c77836b73ae8284c673eabdae7f0880d70a8d (patch)
treec8d2bd82dbd1b99a2991d7cdfaee0e35a91109ed
parentadf218e2e8d855ca9c8477658478658939ed2107 (diff)
downloadguix-3d8c77836b73ae8284c673eabdae7f0880d70a8d.tar.gz
gnu: openssh: Fix cross-compilation.
* gnu/packages/ssh.scm (openssh): Pass --disable-strip argument when
cross-compiling.
-rw-r--r--gnu/packages/ssh.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index de33effc89..7abf710757 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -12,6 +12,7 @@
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -165,7 +166,15 @@ a server that supports the SSH-2 protocol.")
                           "--with-libedit"
 
                           ;; Enable PAM support in sshd.
-                          "--with-pam")
+                          "--with-pam"
+
+                          ;; "make install" runs "install -s" by default,
+                          ;; which doesn't work for cross-compiled binaries
+                          ;; because it invokes 'strip' instead of
+                          ;; 'TRIPLET-strip'.  Work around this.
+                          ,,@(if (%current-target-system)
+                                 '("--disable-strip")
+                                 '()))
 
       #:phases
       (modify-phases %standard-phases