summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2020-08-28 16:27:02 +0200
committerAndreas Enge <andreas@enge.fr>2020-08-28 16:29:04 +0200
commit47ed9ec3b713ab88091b4cc0374091a6fc800288 (patch)
treeb054550e600bc2a30f782825b5166d7b3b067c45
parentb9f3046eaa21387d7ff4a14574a7ebd0c46e10d9 (diff)
downloadguix-47ed9ec3b713ab88091b4cc0374091a6fc800288.tar.gz
gnu: python-requests-mock: Update to 1.8.0.
* gnu/packages/python-web.scm (python-requests-mock): Update to 1.8.0.
[native-inputs]: Add python-purl and python-pytest and remove python-testtools.
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b419c03f7f..42b2bbc1a1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1949,14 +1949,14 @@ library.")
 (define-public python-requests-mock
   (package
     (name "python-requests-mock")
-    (version "1.3.0")
+    (version "1.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "requests-mock" version))
        (sha256
         (base32
-         "0jr997dvk6zbmhvbpcv3rajrgag69mcsm1ai3w3rgk2jdh6rg1mx"))))
+         "09nj8fmyj7xz2mgwyvbw0fl9zybmx2d3qd2hf529vvjc9s24d3z6"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-requests" ,python-requests)
@@ -1967,9 +1967,10 @@ library.")
        ("python-docutils" ,python-docutils)
        ("python-fixtures" ,python-fixtures)
        ("python-mock" ,python-mock)
+       ("python-purl" ,python-purl)
+       ("python-pytest" ,python-pytest)
        ("python-sphinx" ,python-sphinx)
-       ("python-testrepository" ,python-testrepository)
-       ("python-testtools" ,python-testtools)))
+       ("python-testrepository" ,python-testrepository)))
     (home-page "https://requests-mock.readthedocs.org/")
     (synopsis "Mock out responses from the requests package")
     (description