summary refs log tree commit diff
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-30 18:36:08 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-30 18:36:08 -0500
commit5180552e98ed22c5ae858002d312e4a3f26e0f00 (patch)
tree9822b068e011fa5e88f7974a81d468fd1fe0383c
parentf2feb9b9dfb343e563cebc2f120d7fea667865a5 (diff)
downloadguix-5180552e98ed22c5ae858002d312e4a3f26e0f00.tar.gz
gnu: ocaml-ounit: Update to 2.2.3 and rename.
* gnu/packages/ocaml.scm (ocaml-ounit): Update to 2.2.3 and rename.

[definition]: Rename to ocaml-ounit2.
[source]: Replace url-fetch with git-fetch.
[native-inputs]: Remove comment.
[build-system]: Change to dune-build-system.
[arguments]: Remove deletion of check phase, and specify package field.
[description]: Respace to align with column-width.
-rw-r--r--gnu/packages/ocaml.scm37
1 files changed, 19 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a64c68deb1..4ed83d7024 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -974,29 +974,30 @@ compilers that can directly deal with packages.")
      `(("m4" ,m4)
        ("ocaml" ,ocaml-4.07)))))
 
-;; note that some tests may hang for no obvious reason.
-(define-public ocaml-ounit
+(define-public ocaml-ounit2
   (package
-    (name "ocaml-ounit")
-    (version "2.0.8")
-    (source (origin
-              (method url-fetch)
-              (uri (ocaml-forge-uri "ounit" version 1749))
-              (sha256
-               (base32
-                "03ifp9hjcxg4m5j190iy373jcn4039d3vy10kmd8p4lfciwzwc1f"))))
-    (build-system ocaml-build-system)
+    (name "ocaml-ounit2")
+    (version "2.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gildor478/ounit")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "12bsyk5g64rsa94khyl32pjj3fvc58av4vxqrjb3jy14cqyh95y1"))))
+    (build-system dune-build-system)
     (native-inputs
-     `(("libxml2" ,libxml2)           ; for xmllint
+     `(("libxml2" ,libxml2)
        ("ocamlbuild" ,ocamlbuild)))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'check))))             ; tests are run during build
-    (home-page "http://ounit.forge.ocamlcore.org")
+     `(#:package "ounit"))
+    (home-page "https://github.com/gildor478/ounit")
     (synopsis "Unit testing framework for OCaml")
-    (description "Unit testing framework for OCaml.  It is similar to JUnit and
-other XUnit testing frameworks.")
+    (description "Unit testing framework for OCaml.
+It is similar to JUnit and other XUnit testing frameworks.")
     (license license:expat)))
 
 (define-public camlzip