summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 00:50:32 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 21:08:36 +0200
commit56a1ffeb68000068daf3fce3693cc9ee270388a6 (patch)
treed60dd5e47a4818406a4499faf09f9f2b9fc441e3
parentffac364a8e9036a8fd58100037d2390876b9bcc6 (diff)
downloadguix-56a1ffeb68000068daf3fce3693cc9ee270388a6.tar.gz
gnu: libseccomp: Update to 2.5.0.
* gnu/packages/linux.scm (libseccomp): Update to 2.5.0.
[native-inputs]: Add GPERF.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 14bccadce3..b5facf6e89 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5700,7 +5700,7 @@ of flash storage.")
 (define-public libseccomp
   (package
     (name "libseccomp")
-    (version "2.4.3")
+    (version "2.5.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/seccomp/libseccomp/"
@@ -5708,10 +5708,11 @@ of flash storage.")
                                   "/libseccomp-" version ".tar.gz"))
               (sha256
                (base32
-                "07crwxqzvl5k2b90a47ii9wgvi09s9hsy5b5jddw9ylp351d25fg"))))
+                "1wql62cg8f95cwpy057cl764nni9g4sdn5lqj68x22kjs8w71yhz"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("which" ,which)))
+     `(("gperf" ,gperf)
+       ("which" ,which)))
     (synopsis "Interface to Linux's seccomp syscall filtering mechanism")
     (description "The libseccomp library provides an easy to use, platform
 independent, interface to the Linux Kernel's syscall filtering mechanism.  The