summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:15:49 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:03 -0400
commit6073ef75083c3faedaf2a889659e4c61c7b25090 (patch)
treeef0f7897f82860f491679233ab72245b88bd1ec0
parente15793c8d05f6d6d734b8c163c384e84d4606d98 (diff)
downloadguix-6073ef75083c3faedaf2a889659e4c61c7b25090.tar.gz
gnu: mozjs@24: Use invoke.
* gnu/packages/gnuzilla.scm (mozjs-24)[arguments]: Use invoke in the custom
configure phase.
-rw-r--r--gnu/packages/gnuzilla.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 17a6719f86..0f75319387 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -153,15 +153,15 @@ in C/C++.")
                   ;; configure fails if it is followed by SHELL and CONFIG_SHELL
                   (setenv "SHELL" (which "sh"))
                   (setenv "CONFIG_SHELL" (which "sh"))
-                  (zero? (system* "./configure"
-                                  (string-append "--prefix=" out)
-                                  "--with-system-nspr"
-                                  "--enable-system-ffi"
-                                  "--enable-threadsafe"
-                                  ,@(if (string=? "aarch64-linux"
-                                                  (%current-system))
-                                      '("--host=aarch64-unknown-linux-gnu")
-                                      '()))))))))))
+                  (invoke "./configure"
+                          (string-append "--prefix=" out)
+                          "--with-system-nspr"
+                          "--enable-system-ffi"
+                          "--enable-threadsafe"
+                          ,@(if (string=? "aarch64-linux"
+                                          (%current-system))
+                                '("--host=aarch64-unknown-linux-gnu")
+                                '())))))))))
     (inputs
      `(("libffi" ,libffi)
        ("zlib" ,zlib)))))