summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2016-06-07 07:59:07 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-06-11 21:21:16 -0400
commit6fd8f8d6fc3219f18cf48268062d9e98d308eb91 (patch)
tree121d987e9267ccd1cede9387cf02a2a8955f5b43
parent9987c57c74bcea6bf0594951e44ec3b1ba5e6380 (diff)
downloadguix-6fd8f8d6fc3219f18cf48268062d9e98d308eb91.tar.gz
gnu: Add arc-icon-theme.
* gnu/packages/gnome.scm (arc-icon-theme): New variable.
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 365c93be12..c87c371423 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5250,3 +5250,35 @@ like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
 simple and consistent.")
     (home-page "http://snwh.org/moka")
     (license license:gpl3+)))
+
+(define-public arc-icon-theme
+  (package
+    (name "arc-icon-theme")
+    (version "20160605")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/horst3180/arc-icon-theme"
+                                  "/archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1npf0ki0j0llrw9wbffhxxa1cdms0q7b8xlg9m943dd9g7pgdm2p"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'bootstrap
+           (lambda _
+             (zero? (system* "autoreconf" "-vif")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
+    ;; When Arc is missing an icon, it looks in the Moka icon theme for it.
+    (propagated-inputs
+     `(("moka-icon-theme" ,moka-icon-theme)))
+    (synopsis "Arc icon theme")
+    (description "The Arc icon theme provides a set of icons matching the
+style of the Arc GTK theme.  Icons missing from the Arc theme are provided by
+the Moka icon theme.")
+    (home-page "https://github.com/horst3180/arc-icon-theme")
+    (license license:gpl3+)))