summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-05-25 19:57:20 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-26 11:59:39 +0200
commit75baf3193c66662c290585846f736381186d36b1 (patch)
tree88df45de8ea3ea5d5140d43c4628012d9dbfbcdd
parente0775d2a0137711c7150a3b3e01dffd463525b0c (diff)
downloadguix-75baf3193c66662c290585846f736381186d36b1.tar.gz
gnu: Add python-flask-script.
* gnu/packages/python.scm (python-flask-script,
python2-flask-script): New variables.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d28c2eca65..9c2af5ce76 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14703,3 +14703,34 @@ JSON APIs with Behave.")
 
 (define-public python2-behave-web-api
   (package-with-python2 python-behave-web-api))
+
+(define-public python-flask-script
+  (package
+  (name "python-flask-script")
+  (version "2.0.5")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-Script" version))
+      (sha256
+        (base32
+          "0zqh2yq8zk7m9b4xw1ryqmrljkdigfb3hk5155a3b5hkfnn6xxyf"))))
+  (build-system python-build-system)
+  (propagated-inputs
+   `(("python-flask" ,python-flask)
+     ("python-argcomplete" ,python-argcomplete)
+     ("python-werkzeug" ,python-werkzeug)))
+  (native-inputs
+   `(("python-pytest" ,python-pytest)))
+  (home-page
+    "http://github.com/smurfix/flask-script")
+  (synopsis "Scripting support for Flask")
+  (description "The Flask-Script extension provides support for writing
+external scripts in Flask.  This includes running a development server,
+a customised Python shell, scripts to set up your database, cronjobs,
+and other command-line tasks that belong outside the web application
+itself.")
+  (license license:bsd-3)))
+
+(define-public python2-flask-script
+  (package-with-python2 python-flask-script))