summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-25 10:26:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-25 10:47:39 +0200
commit77c729baf2eee1b6ea0b764519c684f1eab18400 (patch)
tree4d6a82f769c902f39cee1ce174d55737d842f7db
parent864cc7ef56d98838de4f7241bd60b345112593c9 (diff)
downloadguix-77c729baf2eee1b6ea0b764519c684f1eab18400.tar.gz
gnu: warzone2100: Use modular Qt.
* gnu/packages/games.scm (warzone2100)[inputs]: Remove qt, add qtbase and
qtscript.
[arguments]: Add build phase "patch-for-qt5.8".
-rw-r--r--gnu/packages/games.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4c297005dc..60d885500c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2784,6 +2784,12 @@ fullscreen, use F5 or Alt+Enter.")
            (lambda _
              (substitute* "icons/Makefile.in"
                (("\\$\\(INSTALL_DATA\\) \\$\\(srcdir\\)/warzone2100.appdata.xml.*") ""))
+             #t))
+         (add-after 'unpack 'patch-for-qt5.8
+           (lambda _
+             (substitute* "lib/widget/editbox.cpp"
+               (("== '\\\\0'")
+                "== QChar('\\0')"))
              #t)))))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("unzip" ,unzip)
@@ -2797,7 +2803,8 @@ fullscreen, use F5 or Alt+Enter.")
               ("libxrandr" ,libxrandr)
               ("openal" ,openal)
               ("physfs" ,physfs)
-              ("qt" ,qt)
+              ("qtbase" ,qtbase)
+              ("qtscript" ,qtscript)
               ("openssl" ,openssl)
               ("quesoglc" ,quesoglc)
               ("sdl2" ,sdl2)))