summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:39:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:39:05 +0200
commit7a0346654d34479878f35556852f89c1f2f6f6c6 (patch)
tree82b68e01528d0cca08f41b477c704ac59a3ee3cf
parentd51b19adabb3449c1919eddd3510439e25d6cace (diff)
downloadguix-7a0346654d34479878f35556852f89c1f2f6f6c6.tar.gz
gnu: eog: Don't create icon cache.
* gnu/packages/gnome.scm (eog)[arguments]: Add phase to skip creating
the gtk icon cache.
[native-inputs]: Remove gtk+:bin.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5843fe9708..862959534f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4141,6 +4141,12 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
                            (assoc-ref %outputs "out") "/lib/eog"))
       #:phases
       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "meson_post_install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t))
         (add-after 'install 'wrap-eog
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out               (assoc-ref outputs "out"))
@@ -4154,7 +4160,6 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
     `(("intltool" ,intltool)
       ("itstool" ,itstool)
       ("glib" ,glib "bin")
-      ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
       ("gobject-introspection" ,gobject-introspection)
       ("pkg-config" ,pkg-config)
       ("xmllint" ,libxml2)))