summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:16:42 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:02:15 +1000
commit90fcedf22030655f0c79fec663276a9e5228c217 (patch)
tree2200382e8c431605fcca390fa69bf95a6bd7b097
parent7c8131c76b3a7e5bb0f133c554b46960b3430b70 (diff)
downloadguix-90fcedf22030655f0c79fec663276a9e5228c217.tar.gz
gnu: Add ruby-brass.
* gnu/packages/ruby.scm (ruby-brass): New variable.
-rw-r--r--gnu/packages/ruby.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 17dfd4a86e..bd03d499a0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3025,3 +3025,31 @@ compliant test framework and can run tests from multiple frameworks in a
 single pass.")
     (home-page "http://rubyworks.github.io/rubytest")
     (license license:bsd-2)))
+
+(define-public ruby-brass
+  (package
+    (name "ruby-brass")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "brass" version))
+       (sha256
+        (base32
+         "154lp8rp1vmg60ri1j4cb8hqlw37z7bn575h899v8hzxwi11sxka"))))
+    (build-system ruby-build-system)
+    (arguments
+     ;; Disable tests to break the cycle brass, lemon, ae, qed, brass.
+     ;; Instead simply test that the library can be require'd.
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "ruby" "-Ilib" "-r" "brass")))))))
+    (synopsis "Basic foundational assertions framework")
+    (description
+     "BRASS (Bare-Metal Ruby Assertion System Standard) is a basic
+foundational assertions framework for other assertion and test frameworks to
+make use of.")
+    (home-page "http://rubyworks.github.io/brass")
+    (license license:bsd-2)))