summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 01:01:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:52:09 +0200
commit9925a2347a96f1125de4acee65eac064b7e02a46 (patch)
tree01b749f1b8a27dacb1848aef12eec0ff66aaf6c8
parent0acbcaa90da1fb9ed0b1ec09d1a0c0674c99093a (diff)
downloadguix-9925a2347a96f1125de4acee65eac064b7e02a46.tar.gz
gnu: htop: Update to 3.0.0.
* gnu/packages/admin.scm (htop): Update to 3.0.0.
[source]: Switch to new upstream.  Use GIT-FETCH and GIT-FILE-NAME.
[native-inputs]: Add autoconf and automake.
[home-page]: Switch to new upstream.
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 6610b8f5c1..5d2c05618a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -514,20 +514,24 @@ or via the @code{facter} Ruby library.")
 (define-public htop
   (package
     (name "htop")
-    (version "2.2.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "http://hisham.hm/htop/releases/"
-                                  version "/htop-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0mrwpb3cpn3ai7ar33m31yklj64c3pp576vh1naqff6f21pq5mnr"))))
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/htop-dev/htop")
+             (commit version)))
+       (sha256
+        (base32 "096gdnpaszs5rfp7qj8npi2jkvdqpp8mznn89f97ykrg6pgagwq4"))
+       (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (inputs
      `(("ncurses" ,ncurses)))
     (native-inputs
-     `(("python" ,python-wrapper)))     ;for scripts/MakeHeader.py
-    (home-page "https://hisham.hm/htop/")
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("python" ,python-wrapper)))     ; for scripts/MakeHeader.py
+    (home-page "https://htop.dev")
     (synopsis "Interactive process viewer")
     (description
      "This is htop, an interactive process viewer.  It is a text-mode