summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-08-29 04:55:45 +0200
committerLeo Famulari <leo@famulari.name>2020-08-29 14:53:15 -0400
commita046c03e139af4dcbe4cab3841fc7377f1152295 (patch)
treec0aa42df30103aa4f87401b6d186b7540b9172fe
parenta790dfe8c466069c2c5942bcedceb924de8a50f2 (diff)
downloadguix-a046c03e139af4dcbe4cab3841fc7377f1152295.tar.gz
gnu: reuse: Update to 0.11.1.
* gnu/packages/license.scm (reuse): Update to 0.11.1.
[native-inputs]: added python-setuptools-scm.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/license.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 36bcb75f8d..975608c79b 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -168,16 +169,17 @@ belonging to various licenses.")
 (define-public reuse
   (package
     (name "reuse")
-    (version "0.7.0")
+    (version "0.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "reuse" version))
        (sha256
-        (base32 "16wn28xxjcm5qlb7bs6jmdkfrkr5v97s59nmi9cn85qcg4gmj7lk"))))
+        (base32 "09qjb4f49vr0a7zrszab8g719ilg2p6b942mr0bgyvplrjikkid5"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-pytest" ,python-pytest)
+       ("python-setuptools-scm" ,python-setuptools-scm)))
     (inputs
      `(("python-binaryornot" ,python-binaryornot)
        ("python-boolean.py" ,python-boolean.py)