summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:03:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:52:09 +0200
commita0484d9ff7866e469ae2044dc2d3fd4bd77ee4c2 (patch)
treebfa753c53ea05a313164d29ec5e872a2ef888593
parent5a9f2ae19b9d50cb8d0d94612c7bd074ce85f0c5 (diff)
downloadguix-a0484d9ff7866e469ae2044dc2d3fd4bd77ee4c2.tar.gz
gnu: scrypt: Install licence file with documentation.
* gnu/packages/crypto.scm (scrypt)[arguments]: Add a
#:license-file-regexp and install the documentation to the same
standard location.
-rw-r--r--gnu/packages/crypto.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 02ad610f90..eb00326ad2 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -529,7 +529,8 @@ user's graphical desktop.")
           "0xy5yhrwwv13skv9im9vm76rybh9f29j2dh4hlh2x01gvbkza8a6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
+     `(#:license-file-regexp "COPYRIGHT"
+       #:phases (modify-phases %standard-phases
         (add-after 'unpack 'patch-command-invocations
           (lambda _
             (substitute* "Makefile.in"
@@ -538,8 +539,8 @@ user's graphical desktop.")
         (add-after 'install 'install-docs
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref %outputs "out"))
-                   (misc (string-append out "/share/doc/scrypt")))
-              (install-file "FORMAT" misc)
+                   (doc (string-append out "/share/doc/" ,name "-" ,version)))
+              (install-file "FORMAT" doc)
               #t))))))
     (inputs
      `(("openssl" ,openssl)))