summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-07 00:42:16 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-07 00:48:12 +0200
commita35f153d54a2e571c88386424c7846b2d4b59689 (patch)
tree10d20730832a4f61e67930486e816e683ccb85be
parent8cc5d3dc4d3c66d19d14b65f75afbfe4a695b6af (diff)
downloadguix-a35f153d54a2e571c88386424c7846b2d4b59689.tar.gz
gnu: python-scipy: Update to 1.3.1.
* gnu/packages/python-xyz.scm (python-scipy): Update to 1.3.1.
(python2-scipy): Keep at version 1.2.2.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5fcc5668c..2827ddf770 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4033,14 +4033,14 @@ operators such as union, intersection, and difference.")
 (define-public python-scipy
   (package
     (name "python-scipy")
-    (version "1.2.2")
+    (version "1.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "scipy" version))
        (sha256
         (base32
-         "1cgvgin8fvckv96hjh3ikmwkra5rif51bdb75ifzf7xbil5iwcx4"))))
+         "1df113c9i6vazsn6y3n9wc22jh737z1g7dmx3mypkdwpdnscyhr6"))))
     (build-system python-build-system)
     (propagated-inputs
      `(("python-numpy" ,python-numpy)
@@ -4136,9 +4136,19 @@ routines such as routines for numerical integration and optimization.")
     (properties `((python2-variant . ,(delay python2-scipy))))
     (license license:bsd-3)))
 
+;; Version 1.2.2 is the last version to support Python 2
 (define-public python2-scipy
-  (package-with-python2
-   (strip-python2-variant python-scipy)))
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-scipy)))
+    (version "1.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "scipy" version))
+       (sha256
+        (base32
+         "1cgvgin8fvckv96hjh3ikmwkra5rif51bdb75ifzf7xbil5iwcx4"))))))
 
 (define-public python-socksipy-branch
   (package