summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-26 16:15:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-26 21:52:46 +0100
commitae9cfc647daea456823adecba28021896b51407e (patch)
treec070bf554eafa50427f5e06c09a0f04ed827b69a
parent6fda3a6cb421121d6ff600b9bc836e24c18a433a (diff)
downloadguix-ae9cfc647daea456823adecba28021896b51407e.tar.gz
gnu: LibUV: Add version 1.34.2.
* gnu/packages/libevent.scm (libuv/latest): New public variable.
-rw-r--r--gnu/packages/libevent.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 338b2afd4e..3754a5c427 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -130,6 +130,20 @@ resolution, asynchronous file system operations, and threading primitives.")
     ;; details.  Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
     (license (list expat cc-by4.0))))
 
+;; This newer version of LibUV is required by 'node'.  Package it separately
+;; to avoid massive rebuilds.
+(define-public libuv/latest
+  (package/inherit
+   libuv
+   (version "1.34.2")
+   (source (origin
+             (method url-fetch)
+             (uri (string-append "https://dist.libuv.org/dist/v" version
+                                 "/libuv-v" version ".tar.gz"))
+             (sha256
+              (base32
+               "0inzk8qpw78im3fiazrc54qi1gcapbs8dhf0hk3kwpzg0i2kpnb5"))))))
+
 (define-public perl-anyevent
   (package
     (name "perl-anyevent")