summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-10 15:54:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-10 15:55:19 +0200
commitb6239e452c5d7c697abfafe800b8722efd96644d (patch)
treea0d547dbe08385e940c432b869d3b9ff48b1a260
parent56ccafbe7c4780c0bd69e76afe12311a4b8ac53a (diff)
downloadguix-b6239e452c5d7c697abfafe800b8722efd96644d.tar.gz
gnu: librsvg: Use 'modify-phases' syntax.
* gnu/packages/gnome.scm (librsvg)[arguments]: Use 'modify-phases'
syntax.
-rw-r--r--gnu/packages/gnome.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5a9d145ece..f4e8428dab 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1178,27 +1178,26 @@ dealing with different structured file formats.")
     (build-system gnu-build-system)
     (arguments
      `(#:phases
-       (alist-cons-before
-        'configure 'pre-configure
-        (lambda* (#:key inputs #:allow-other-keys)
-          (substitute* "gdk-pixbuf-loader/Makefile.in"
-            ;; By default the gdk-pixbuf loader is installed under
-            ;; gdk-pixbuf's prefix.  Work around that.
-            (("gdk_pixbuf_moduledir = .*$")
-             (string-append "gdk_pixbuf_moduledir = "
-                            "$(prefix)/lib/gdk-pixbuf-2.0/2.10.0/"
-                             "loaders\n"))
-            ;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
-            (("gdk_pixbuf_cache_file = .*$")
-             "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n")))
-        (alist-cons-after
-         'unpack 'remove-failing-test
-         ;; This test fails on aarch64.
-         (lambda _
-           (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children.svg")
-           (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children-ref.png")
-           #t)
-        %standard-phases))))
+       (modify-phases %standard-phases
+         (add-before 'configure 'pre-configure
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "gdk-pixbuf-loader/Makefile.in"
+               ;; By default the gdk-pixbuf loader is installed under
+               ;; gdk-pixbuf's prefix.  Work around that.
+               (("gdk_pixbuf_moduledir = .*$")
+                (string-append "gdk_pixbuf_moduledir = "
+                               "$(prefix)/lib/gdk-pixbuf-2.0/2.10.0/"
+                                "loaders\n"))
+               ;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
+               (("gdk_pixbuf_cache_file = .*$")
+                "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
+             #t))
+         (add-after 'unpack 'remove-failing-test
+           ;; This test fails on aarch64.
+           (lambda _
+             (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children.svg")
+             (delete-file "tests/fixtures/reftests/bugs/777834-empty-text-children-ref.png")
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")                               ; glib-mkenums, etc.