summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 20:31:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:16:59 +0200
commitc3d1448411404e7415d75b0f44263ce14eaf89a0 (patch)
tree63bc5d2e51fb221353336d3d0e438f08fc5d6db1
parentd195e4eb744134e9a299f021f232c41f1219593c (diff)
downloadguix-c3d1448411404e7415d75b0f44263ce14eaf89a0.tar.gz
gnu: rsound: Return #t from phases.
* gnu/packages/audio.scm (rsound)[arguments]: Substitute INVOKE for
SYSTEM*.
-rw-r--r--gnu/packages/audio.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2245bd9037..98f66aae88 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2791,9 +2791,8 @@ synthesizer written in C++.")
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (setenv "CC" "gcc")
-             (zero?
-              (system* "./configure"
-                       (string-append "--prefix=" (assoc-ref outputs "out")))))))
+             (invoke "./configure"
+                     (string-append "--prefix=" (assoc-ref outputs "out"))))))
        ;; No 'check' target.
        #:tests? #f))
     (home-page "http://themaister.net/rsound.html")