summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-05-05 10:45:55 +0200
committerAndreas Enge <andreas@enge.fr>2013-05-05 10:45:55 +0200
commitdcc9053aff12005bc5c1d2305a3c061ee478976a (patch)
treef99cebef97b4aa50279406922e71bef6b41cdd3f
parent3a08a411887704ddce9f01336608fba4ba48db4d (diff)
downloadguix-dcc9053aff12005bc5c1d2305a3c061ee478976a.tar.gz
gnu: Add libxaw3d.
* gnu/packages/xorg.scm (libxaw3d): New variable.
-rw-r--r--gnu/packages/xorg.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6ac917a382..cde6475a09 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -177,7 +177,7 @@ tracking.")
 
 
 
-    ;; packages without propagated input
+;; packages without propagated input
 ;; (rationale for this separation: The packages in PROPAGATED_INPUTS need to
 ;; be defined first, the split makes book-keeping easier.)
 
@@ -4846,3 +4846,33 @@ emulation to complete hardware acceleration for modern GPUs.")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
+
+
+;; package outside the x.org system proper of height 5
+
+(define-public libxaw3d
+  (package
+    (name "libxaw3d")
+    (version "1.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/lib/libXaw3d-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "0awplv1nf53ywv01yxphga3v6dcniwqnxgnb0cn4khb121l12kxp"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+      `(("libxext" ,libxext)
+        ("libxmu" ,libxmu)
+        ("libxt" ,libxt)))
+    (inputs
+      `(("libx11" ,libx11)
+        ("pkg-config" ,pkg-config)))
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "xorg implementation of the X Window System")
+    (description "X.org provides an implementation of the X Window System")
+    (license license:x11)))