summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosé Miguel Sánchez García <jmi2k@openmailbox.org>2017-05-26 18:35:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-26 20:30:32 +0200
commite46bf22391b97a515f7a1cf975e019e3f3f5df3b (patch)
treec05a61f53c46c82d164d840473fc5f2f34d1be07
parent7a0efa77a47a81f8611a753d5a56f4d890ebe9de (diff)
downloadguix-e46bf22391b97a515f7a1cf975e019e3f3f5df3b.tar.gz
gnu: python-xcffib: Fix libxcb.so.1 path.
* gnu/packages/python.scm (python-xcffib)[arguments]<#:phases>: Add phase to
embed full path to libxcb.so.1.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c42daa106a..2f3219c58e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4765,10 +4765,16 @@ a front-end for C compilers or analysis tools.")
      `(("python-cffi" ,python-cffi) ; used at run time
        ("python-six" ,python-six)))
     (arguments
-     `(;; FIXME: Tests cannot load libxcb.so.1
+     `(;; FIXME: Tests need more work. See ".travis.yml" in the repository.
        #:tests? #f
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-libxcb-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((libxcb (assoc-ref inputs "libxcb")))
+               (substitute* '("xcffib/__init__.py")
+                 (("^soname = \"") (string-append "soname = \"" libxcb "/lib/")))
+               #t)))
          (add-after 'install 'install-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((doc (string-append (assoc-ref outputs "out") "/share"