summary refs log tree commit diff
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-05-11 22:34:04 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-13 23:16:17 +0200
commite5d92c1ce197ec6da891f69565fe550f502f8e7c (patch)
treea48c27f83a41f6972aefa0a7f156763e3ed1ab60
parent44cea5784128353f0449899ae4ca7fdb5259c024 (diff)
downloadguix-e5d92c1ce197ec6da891f69565fe550f502f8e7c.tar.gz
gnu: Add ghc-array.
* gnu/packages/haskell.scm (ghc-array): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9b26ff56f2..c65df28218 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -13,6 +13,7 @@
 ;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9466,4 +9467,27 @@ system dependencies.")
 address string against RFC 5322.")
     (license license:bsd-3)))
 
+(define-public ghc-array
+  (package
+   (name "ghc-array")
+   (version "0.5.2.0")
+   (source
+    (origin
+     (method url-fetch)
+     (uri
+      (string-append "https://hackage.haskell.org/package/array-0.5.2.0/array-"
+                     version ".tar.gz"))
+     (file-name (string-append name "-" version ".tar.gz"))
+     (sha256
+      (base32
+       "12v83s2imxb3p2crnlzrpjh0nk6lpysw9bdk9yahs6f37csa5jaj"))))
+   (build-system haskell-build-system)
+   (synopsis "Haskell @code{Data.Array} module")
+   (description "In addition to providing the @code{Data.Array} module as
+specified in the Haskell 2010 Language Report, this package defines the
+classes @code{IArray} of immutable arrays and @code{MArray} of arrays mutable
+within appropriate monads, as well as some instances of these classes.")
+   (home-page "https://hackage.haskell.org/package/array")
+   (license license:bsd-3)))
+
 ;;; haskell.scm ends here