summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-03 22:49:07 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-03 22:52:19 +0100
commitf2122ed1dc89353cad49a0ade54060d9946ba8d3 (patch)
treec3ad8e165e173f803ed48e659371ca05bd505baa
parent845d48e7a1a9068e1d6df0c1e0294633c05b7c7e (diff)
downloadguix-f2122ed1dc89353cad49a0ade54060d9946ba8d3.tar.gz
gnu: dbus: Update to 1.8.10.
* gnu/packages/glib.scm (dbus): Update to 1.8.10.
  (dbus-1.8.10): Remove.
-rw-r--r--gnu/packages/glib.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index b472349d49..fd4aa8860d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -56,8 +56,7 @@
 (define dbus
   (package
     (name "dbus")
-    (version "1.8.8")
-    (replacement dbus-1.8.10)                     ;fix for CVE-2014-7824
+    (version "1.8.10")
     (source (origin
              (method url-fetch)
              (uri
@@ -65,7 +64,7 @@
                              version ".tar.gz"))
              (sha256
               (base32
-               "1zfi5grrlryppgrl23im82cqw6l9fk1wlc2ayvzx0yd994v2dayz"))
+               "13mgvwigm931r8n9363imnn0vn6dvc0m322k3p8fs5c8nvyqggqh"))
              (patches (list (search-patch "dbus-localstatedir.patch")))))
     (build-system gnu-build-system)
     (arguments
@@ -116,20 +115,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
-(define-public dbus-1.8.10
-  (let ((real-version "1.8.10"))
-    (package (inherit dbus)
-      (source (origin
-                (method url-fetch)
-                (uri
-                 (string-append "http://dbus.freedesktop.org/releases/dbus/dbus-"
-                                real-version ".tar.gz"))
-                (sha256
-                 (base32
-                  "13mgvwigm931r8n9363imnn0vn6dvc0m322k3p8fs5c8nvyqggqh"))
-                (patches (list (search-patch "dbus-localstatedir.patch")))))
-      (replacement #f))))
-
 (define glib
   (package
    (name "glib")