summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 14:08:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:56 +0100
commitf579a1d2fa21d59cfbc71643094f098e8cf47190 (patch)
tree9b42a69559cefe44997c2a48706a362b9647985b
parent314144d2128f99e05312b6622734f645a6f5cac4 (diff)
downloadguix-f579a1d2fa21d59cfbc71643094f098e8cf47190.tar.gz
gnu: Switch from renderproto to xorgproto.
* gnu/packages/mate.scm (mate-control-center,
mate-screensaver)[native-inputs]: Remove RENDERPROTO.
* gnu/packages/xorg.scm (renderproto)[properties]: Mark as superseded by XORGPROTO.
(libxrender)[propagated-inputs]: Replace RENDERPROTO with XORGPROTO.
[inputs]: Remove XORGPROTO.
* gnu/packages/xorg.scm (xorg-server)[inputs]: Remove RENDERPROTO.
-rw-r--r--gnu/packages/mate.scm2
-rw-r--r--gnu/packages/xorg.scm10
2 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8c3ea160df..7b16127971 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -923,7 +923,6 @@ icons on the MATE desktop.  It works on local and remote file systems.")
        ("intltool" ,intltool)
        ("yelp-tools" ,yelp-tools)
        ("desktop-file-utils" ,desktop-file-utils)
-       ("renderproto" ,renderproto)
        ("scrnsaverproto" ,scrnsaverproto)
        ("xorgproto" ,xorgproto)
        ("xmodmap" ,xmodmap)
@@ -1193,7 +1192,6 @@ Re-decorates windows on un-maximise.
        ("intltool" ,intltool)
        ("mate-common" ,mate-common)
        ("pkg-config" ,pkg-config)
-       ("renderproto" ,renderproto)
        ("scrnsaverproto" ,scrnsaverproto)
        ("which" ,which)
        ("xorgproto" ,xorgproto)))
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 4d62c8896a..17f22b9197 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1727,8 +1727,8 @@ of user actions in the X Window System.")
     (description
      "Rendering Extension defines a protcol for a digital image composition
 as the foundation of a new rendering model within the X Window System.")
-    (license license:x11)))
-
+    (license license:x11)
+    (properties `((superseded . ,xorgproto)))))
 
 (define-public resourceproto
   (package
@@ -4633,10 +4633,9 @@ cannot be adequately worked around on the client side of the wire.")
             "0j89cnb06g8x79wmmnwzykgkkfdhin9j7hjpvsxwlr3fz1wmjvf0"))))
     (build-system gnu-build-system)
     (propagated-inputs
-      `(("renderproto" ,renderproto)))
+      `(("xorgproto" ,xorgproto)))
     (inputs
-      `(("xorgproto" ,xorgproto)
-        ("libx11" ,libx11)))
+      `(("libx11" ,libx11)))
     (native-inputs
       `(("pkg-config" ,pkg-config)))
     (home-page "https://www.x.org/wiki/")
@@ -5098,7 +5097,6 @@ over Xlib, including:
       `(("libpciaccess" ,libpciaccess)
         ("mesa" ,mesa)
         ("pixman" ,pixman)
-        ("renderproto" ,renderproto)
         ("resourceproto" ,resourceproto)
         ("scrnsaverproto" ,scrnsaverproto)
         ("xineramaproto" ,xineramaproto)