summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-15 22:56:29 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-16 09:43:28 +0200
commitfad176c4e20424c3dacddac8820237cf0b93a2c0 (patch)
tree269f7c9e06e2b4e96652285fe262c3bb3ff34980
parentd2b014aab3bb902667a028951f9af860377a809f (diff)
downloadguix-fad176c4e20424c3dacddac8820237cf0b93a2c0.tar.gz
gnu: Add libde265.
* gnu/packages/video.scm (libde265): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/video.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 44326420a8..95567994f1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -319,6 +319,30 @@ television and DVD.  It is also known as AC-3.")
 shared library and encoder and decoder command-line executables.")
     (license license:bsd-2)))
 
+(define-public libde265
+  (package
+    (name "libde265")
+    (version "1.0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/strukturag/libde265")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qisj8ryzbknam3hk81rq70fsd9mcpxm898bqygvbsmbwyvmz3pg"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ;there are no tests
+    (home-page "https://www.libde265.org/")
+    (synopsis "Open h.265 video codec implementation")
+    (description
+     "libde265 is an implementation of the h.265 video codec.  It is written
+from scratch and has a plain C API to enable a simple integration into other
+software.")
+    (license license:lgpl3+)))
+
 (define-public libmpeg2
   (package
     (name "libmpeg2")