summary refs log tree commit diff
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2019-03-19 11:28:53 +0100
committerClément Lassieur <clement@lassieur.org>2019-03-19 11:32:30 +0100
commit3e0df6cd4ad7b4eba6564976c98a94d131d44494 (patch)
tree061b9e6f2c6cceb4a4b2cb4cd1aa700f89c13138
parentdfb49d7820cfd5834242f4f38718141e192ecc12 (diff)
downloadguix-3e0df6cd4ad7b4eba6564976c98a94d131d44494.tar.gz
gnu: Add emacs-org-re-reveal.
* gnu/packages/emacs-xyz.scm (emacs-org-re-reveal): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index eb4dbc098d..76b739b6f6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10009,6 +10009,7 @@ The default setup uses helm-bibtex.
 You should really read org-ref.org in this package for details.")
       (license license:gpl3+))))
 
+;; This project is unmaintained.  Please use emacs-org-re-reveal instead.
 (define-public emacs-org-reveal
   (let ((commit "1cdd088ec5fab631c564dca7f9f74fd3e9b7d4d4"))
     (package
@@ -10031,6 +10032,30 @@ to create beautiful presentations (slides) with 3D effects from simple but
 powerful Org contents.")
       (license license:gpl3+))))
 
+(define-public emacs-org-re-reveal
+  (package
+    (name "emacs-org-re-reveal")
+    (version "1.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/oer/org-re-reveal.git")
+                    (commit "50cc6574c77f12d423f6cd096d8f76feb3673abc")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1v3z30gpimg4spf6zzqwp9b597zxk89h0vpq6xp58js4rjg4ixk8"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-htmlize" ,emacs-htmlize)
+       ("emacs-org" ,emacs-org)))
+    (home-page "https://gitlab.com/oer/org-re-reveal")
+    (synopsis "Build HTML presentations with reveal.js from Org source files")
+    (description "This project started as fork of org-reveal.  It provides an
+export back-end for HTML presentations with reveal.js from Org mode source
+files.")
+    (license license:gpl3+)))
+
 (define-public emacs-add-hooks
   (package
     (name "emacs-add-hooks")