summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-10 03:02:50 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 00:04:36 +0200
commit3ef85c1118e19a66d76f21de67beca6f93c920c3 (patch)
tree31fd19bb6887bbcbd1f35793cb00ba45e5c76cb4
parent78f46e65bd1433009bd974b9d150e5675e5a7201 (diff)
downloadguix-3ef85c1118e19a66d76f21de67beca6f93c920c3.tar.gz
gnu: Add python-twine.
* gnu/packages/python.scm (python-twine, python2-twine): New variables.
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 952af29052..6ffd468b3e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16411,3 +16411,31 @@ created by running @code{python setup.py develop}).")
 
 (define-public python2-pkginfo
   (package-with-python2 python-pkginfo))
+
+(define-public python-twine
+  (package
+    (name "python-twine")
+    (version "1.9.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "twine" version))
+        (sha256
+          (base32
+            "1ay1b6kdq6k4bfbjsvf6ymj41wrgpvinhxndb09355pwhxwmp96a"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-tqdm" ,python-tqdm)
+       ("python-pkginfo", python-pkginfo)
+       ("python-requests" ,python-requests)
+       ("python-requests-toolbelt" ,python-requests-toolbelt)))
+    (home-page "https://github.com/pypa/twine")
+    (synopsis "Collection of utilities for interacting with PyPI")
+    (description
+      "@code{twine} currently supports registering projects and uploading
+distributions.  It authenticates the user over HTTPS, allows them to pre-sign
+their files and supports any packaging format (including wheels).")
+    (license license:asl2.0)))
+
+(define-public python2-twine
+  (package-with-python2 python-twine))