summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-05-09 08:51:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-05-09 08:51:24 +0300
commit59898500dda7901d5e467754f2522f883fbf68ba (patch)
treefe1affbe8a51e5632efc4656b706052645847685
parent9034dc8f2a81d5f645548edfaa43f7698062105b (diff)
downloadguix-59898500dda7901d5e467754f2522f883fbf68ba.tar.gz
gnu: wxwidgets: Fix building on aarch64-linux.
* gnu/packages/wxwidgets.scm (wxwidgets)[arguments]: On aarch64-linux
us a '--build' configure-flag to work around ancient autotools.
-rw-r--r--gnu/packages/wxwidgets.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index 077195cca7..329920d7c1 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -70,12 +71,16 @@
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (arguments
-     '(#:configure-flags
+     `(#:configure-flags
        '("--with-regex" "--with-libmspack"
          "--with-sdl"
          "--enable-webview"
          "--enable-webkit"
-         "--enable-webviewwebkit")
+         "--enable-webviewwebkit"
+         ,@(if (string=? "aarch64-linux"
+                         (%current-system))
+             '("--build=aarch64-unknown-linux-gnu")
+             '()))
        #:make-flags
        (list (string-append "LDFLAGS=-Wl,-rpath="
                             (assoc-ref %outputs "out") "/lib"))