summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-14 23:27:43 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-23 22:55:25 +0200
commitb12fe1e5170b7a49d8c9c5cd39afe9e267b4614a (patch)
tree318cdd1423e236a0aa4f6ccc0295f7b126a506ff
parentec4e8ad724084a8ba3b62f77821367ff89eeff6d (diff)
downloadguix-b12fe1e5170b7a49d8c9c5cd39afe9e267b4614a.tar.gz
gnu: Add java-assertj.
* gnu/packages/java.scm (java-assertj): New variable.
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 38fc68681a..d6e425e24b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6165,3 +6165,34 @@ Java 6 and above.")
      `(("guice" ,java-guice)
        ("servlet" ,java-tomcat)
        ,@(package-inputs java-guice)))))
+
+(define-public java-assertj
+  (package
+    (name "java-assertj")
+    (version "3.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/joel-costigliola/"
+                                  "assertj-core/archive/"
+                                  "assertj-core-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1kf124fxskf548rklkg86294w2x6ajqrff94rrhyqns31danqkfz"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "java-assertj.jar"
+       #:jdk ,icedtea-8
+       #:source-dir "src/main/java"
+       #:tests? #f)); depends on tng-junit which depends on assertj
+    (inputs
+     `(("cglib" ,java-cglib)
+       ("junit" ,java-junit)
+       ("hamcrest" ,java-hamcrest-core)))
+    (native-inputs
+     `(("mockito" ,java-mockito-1)))
+    (home-page "https://joel-costigliola.github.io/assertj/index.html")
+    (synopsis "Fluent assertions for java")
+    (description "AssertJ core is a Java library that provides a fluent
+interface for writing assertions.  Its main goal is to improve test code
+readability and make maintenance of tests easier.")
+    (license license:asl2.0)))