summary refs log tree commit diff
diff options
context:
space:
mode:
authorBen Woodcroft <b.woodcroft@uq.edu.au>2015-06-09 16:10:51 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-12 12:57:30 +0200
commit1e44cf8b0ffe88f2675718c0a0f5119c87a8bf6a (patch)
treef40c3353e6292b69af34e5e46bb58f2b54ad00e4
parent47da6268c45796d858eccff601e17ce11a7aeb62 (diff)
downloadguix-1e44cf8b0ffe88f2675718c0a0f5119c87a8bf6a.tar.gz
gnu: Add OrfM.
* gnu/packages/bioinformatics.scm (orfm): New variable.

Signed-off-by: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index df627fbe48..7175ecf41d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1101,6 +1101,27 @@ RNA-Seq, the MISO model uses Bayesian inference to compute the probability
 that a read originated from a particular isoform.")
     (license license:gpl2)))
 
+(define-public orfm
+  (package
+    (name "orfm")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/wwood/OrfM/releases/download/v"
+                    version "/orfm-" version ".tar.gz"))
+              (sha256
+               (base32
+                "00jqvlspj9662ni9r4n1snxfnwkzc02i46g5nk1kwjshi6v3vgg3"))))
+    (build-system gnu-build-system)
+    (inputs `(("zlib" ,zlib)))
+    (synopsis "Simple and not slow open reading frame (ORF) caller")
+    (description
+     "An ORF caller finds stretches of DNA that when translated are not
+interrupted by stop codons.  OrfM finds and prints these ORFs.")
+    (home-page "https://github.com/wwood/OrfM")
+    (license license:lgpl3+)))
+
 (define-public python2-pbcore
   (package
     (name "python2-pbcore")