summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-12 03:29:43 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-12 03:33:07 +0100
commit3368917c26e7b293168cc1201e35beb9a28f98e5 (patch)
tree3e4bfb9ac56ca8f6e48f5b80490baa23134f6cf5
parent75d9d8afc1e8a82780f5181e109252ec6496bf4f (diff)
downloadguix-3368917c26e7b293168cc1201e35beb9a28f98e5.tar.gz
gnu: libstrophe: Don't use unstable tarball.
* gnu/packages/messaging.scm (libstrophe)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/messaging.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9c8e3366f9..73af29360e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1590,14 +1590,15 @@ manual SSL certificate verification.")
   (package
     (name "libstrophe")
     (version "0.9.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/strophe/libstrophe/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1zm4a7009lshwgj5x11vslrxj2zjgwshhhad3p05kvbp47v7jfwa"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/strophe/libstrophe.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1g1l0w9z9hdy5ncdvd9097gi7k7783did6py5h9camlpb2fnk5mk"))))
     (build-system gnu-build-system)
     (inputs
      `(("expat" ,expat)