summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-04 15:09:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-04 15:09:33 +0100
commit58b5e1ad7c6013a4116587a89398cd9cbe10c7eb (patch)
tree57b38ce172e867e9440a4b633d1892422892bd27
parente9eac58a58c63d40caa39a0b0ca32e5fcb1de6b6 (diff)
downloadguix-58b5e1ad7c6013a4116587a89398cd9cbe10c7eb.tar.gz
gnu: rust-syn-1: Update to 1.0.53.
* gnu/packages/crates-io.scm (rust-syn-1): Update to 1.0.53.  Fix indentation.
[description]: Make it a full sentence.
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 74496d99a7..320b2f513f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28063,15 +28063,14 @@ browsers.")
 (define-public rust-syn-1
   (package
     (name "rust-syn")
-    (version "1.0.40")
+    (version "1.0.53")
     (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "syn" version))
-        (file-name (string-append name "-" version ".crate"))
-        (sha256
-         (base32
-          "0l437lsnv289y64pgl2mfvr1vgrb2hix5bb5a4rbjncvqly7sgwn"))))
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "syn" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0s3y325n7s6gsg4wg0dq0pxymhv1x8qd4nmsp8my2kf24h3y4cw8"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
@@ -28093,7 +28092,9 @@ browsers.")
         ("rust-walkdir" ,rust-walkdir-2))))
     (home-page "https://github.com/dtolnay/syn")
     (synopsis "Parser for Rust source code")
-    (description "Parser for Rust source code")
+    (description
+     "Syn is a parsing library for parsing a stream of Rust tokens into
+a syntax tree of Rust source code.")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-syn-0.15