summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 14:01:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 14:03:21 +0100
commit5ac55aea8b78439cc72b70718cb7922599182712 (patch)
treedd7be5dede6ed34da5a5873cbef0aab07c22e5ff
parent134404b437a2b17bbe072b263884f6ff5d8daf86 (diff)
downloadguix-5ac55aea8b78439cc72b70718cb7922599182712.tar.gz
gnu: r-biocstyle: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biocstyle): Move from here...
* gnu/packages/bioconductor.scm (r-biocstyle): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index c02d1c7877..ca9bcc07eb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8477,6 +8477,34 @@ monograph.")
 different graph related packages produced by Bioconductor.")
     (license license:artistic2.0)))
 
+(define-public r-biocstyle
+  (package
+    (name "r-biocstyle")
+    (version "2.18.1")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BiocStyle" version))
+              (sha256
+               (base32
+                "0rsxyna4dd99x42vc82mlkxx774vb9375llpakg53max1hhwkrqp"))))
+    (properties
+     `((upstream-name . "BiocStyle")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocmanager" ,r-biocmanager)
+       ("r-bookdown" ,r-bookdown)
+       ("r-knitr" ,r-knitr)
+       ("r-rmarkdown" ,r-rmarkdown)
+       ("r-yaml" ,r-yaml)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/BiocStyle")
+    (synopsis "Bioconductor formatting styles")
+    (description "This package provides standard formatting styles for
+Bioconductor PDF and HTML documents.  Package vignettes illustrate use and
+functionality.")
+    (license license:artistic2.0)))
+
 (define-public r-biocviews
   (package
     (name "r-biocviews")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8169ff4f26..c90dcada7b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7718,34 +7718,6 @@ including VCF header and contents in RDF and JSON.")
     (home-page "https://github.com/vcflib/bio-vcf")
     (license license:expat)))
 
-(define-public r-biocstyle
-  (package
-    (name "r-biocstyle")
-    (version "2.18.1")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "BiocStyle" version))
-              (sha256
-               (base32
-                "0rsxyna4dd99x42vc82mlkxx774vb9375llpakg53max1hhwkrqp"))))
-    (properties
-     `((upstream-name . "BiocStyle")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biocmanager" ,r-biocmanager)
-       ("r-bookdown" ,r-bookdown)
-       ("r-knitr" ,r-knitr)
-       ("r-rmarkdown" ,r-rmarkdown)
-       ("r-yaml" ,r-yaml)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/BiocStyle")
-    (synopsis "Bioconductor formatting styles")
-    (description "This package provides standard formatting styles for
-Bioconductor PDF and HTML documents.  Package vignettes illustrate use and
-functionality.")
-    (license license:artistic2.0)))
-
 (define-public r-bioccheck
   (package
     (name "r-bioccheck")