summary refs log tree commit diff
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 14:30:04 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-25 21:17:16 +0800
commitca302c3e8cbedb62f41f25eee4c360064c368573 (patch)
treeebf5c7b047d37390d81277075b9fa3a1bb8c0dfa
parentbf0da63aaeb99445de362effe77c72ff9aff942d (diff)
downloadguix-ca302c3e8cbedb62f41f25eee4c360064c368573.tar.gz
gnu: Add lxqt-openssh-askpass.
* gnu/packages/lxqt.scm (lxqt-openssh-askpass): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lxqt.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 7cc077ee1f..7c0e866ef0 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -470,6 +470,39 @@ as a whole and are not limited to distinct applications.")
 according to the Desktop Notifications Specification.")
     (license license:lgpl2.1+)))
 
+(define-public lxqt-openssh-askpass
+  (package
+    (name "lxqt-openssh-askpass")
+    (version "0.13.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+                           version "/" name "-" version ".tar.xz"))
+       (sha256
+        (base32 "0l2272gya8jgv71bvg2hz37lnhiznv4ng3j0p6j79f99hwb5ygpk"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("kwindowsystem" ,kwindowsystem)
+       ("liblxqt" ,liblxqt)
+       ("libqtxdg" ,libqtxdg)
+       ("qtbase" ,qtbase)
+       ("qtsvg" ,qtsvg)
+       ("qtx11extras" ,qtx11extras)))
+    (native-inputs
+     `(("lxqt-build-tools" ,lxqt-build-tools)
+       ("qttools" ,qttools)))
+    (arguments
+     '(#:tests? #f                      ; no tests
+       #:configure-flags
+       ;; TODO: prefetch translations files from 'lxqt-l10n'.
+       '("-DPULL_TRANSLATIONS=NO")))
+    (home-page "https://lxqt.org/")
+    (synopsis "GUI to query passwords on behalf of SSH agents")
+    (description "lxqt-openssh-askpass is a GUI to query credentials on behalf
+of other programs.")
+    (license license:lgpl2.1+)))
+
 (define-public lxqt-panel
   (package
     (name "lxqt-panel")