summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-16 02:45:49 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-16 02:45:49 +0100
commit154d207c435a5a16d44bcb98dbb31c124dc87574 (patch)
tree1f15fe0a6ea102b3b7e0d0d8eb63e64f486283b9
parent80ce42bdbf3f795ba6b91cebd472261b1e141a4a (diff)
downloadguix-154d207c435a5a16d44bcb98dbb31c124dc87574.tar.gz
gnu: python-apsw: Fix tests.
* gnu/packages/python.scm (python-apsw, python2-apsw)[arguments]: Use
  'modify-phases'. Add installed PYTHONPATH before running tests.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 90c9ecd413..7e7e54f54f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5155,13 +5155,12 @@ implementation of D-Bus.")
       `(("sqlite" ,sqlite)))
     (arguments
      `(#:phases
-        ;; swap check and install phases
-        (alist-cons-after
-         'install 'check
-         (assoc-ref %standard-phases 'check)
-         (alist-delete
-          'check
-          %standard-phases))))
+       (modify-phases %standard-phases
+         (delete 'check)
+         (add-after 'install 'check
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (zero? (system* "python" "setup.py" "test")))))))
     (home-page "https://github.com/rogerbinns/apsw/")
     (synopsis "Another Python SQLite Wrapper")
     (description "APSW is a Python wrapper for the SQLite