summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-17 14:01:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-17 14:02:57 +0100
commit1ecbd859a10d42ead1d2b68342b89ab19952df88 (patch)
treede71ceaa81f1d18666222df9a766bc5d99b15349
parent369eee8763ca34b427860a86c8fe2db0963b52ae (diff)
downloadguix-1ecbd859a10d42ead1d2b68342b89ab19952df88.tar.gz
gnu: ghc-mtl: Remove ghc-transformers from inputs.
* gnu/packages/haskell.scm (ghc-mtl)[arguments]: Explain why we need to allow
a newer version of the transformers package.
[inputs]: Remove ghc-transformers.
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 426939ec5b..1a7e06dd81 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1675,10 +1675,11 @@ configuration.  This library provides the common bits for writing custom
         (base32
          "1icdbj2rshzn0m1zz5wa7v3xvkf6qw811p4s7jgqwvx1ydwrvrfa"))))
     (build-system haskell-build-system)
+    ;; This is an official revision, relaxing the requirement transformers ==
+    ;; 0.4 to transformers >= 0.4 && < 0.6; see
+    ;; https://hackage.haskell.org/package/mtl-2.2.1/revision/1.cabal
     (arguments
      `(#:configure-flags (list "--allow-newer=transformers")))
-    (inputs
-     `(("ghc-transformers" ,ghc-transformers)))
     (home-page "https://github.com/ekmett/mtl")
     (synopsis
      "Monad classes, using functional dependencies")