summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-26 10:25:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-26 10:25:15 +0200
commit29b3c0898f17f7df7cb5c7bd9b0adaf1c38231be (patch)
treea46f10697aedcdb4fb8b1d3c29fc6483136b796e
parent20ca345899ee046426201c07e9e2eb9d2737645a (diff)
downloadguix-29b3c0898f17f7df7cb5c7bd9b0adaf1c38231be.tar.gz
gnu: Add emacs-inheritenv.
* gnu/packages/emacs-xyz.scm (emacs-inheritenv): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5d3bc944fa..8dad498e03 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15082,6 +15082,27 @@ query them from the comfort of your editor.")
     (home-page "https://github.com/hrs/engine-mode")
     (license license:gpl3+)))
 
+(define-public emacs-inheritenv
+  (package
+    (name "emacs-inheritenv")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/purcell/inheritenv")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ygzf70vfb7qwpsllcq5i3brprsnx3sxy2zng02mzwrr5jkx4ypc"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/purcell/inheritenv/releases")
+    (synopsis "Emacs temp buffers inherit buffer-local environment variables")
+    (description
+     "Inheritenv provides tools to execute processes inheriting the calling
+buffer's environment.")
+    (license license:gpl3+)))
+
 (define-public emacs-envrc
   (package
     (name "emacs-envrc")