summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Prat <vprat@deeplinks.com>2022-04-08 15:11:21 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-15 19:13:02 +0200
commit304c6b395cdf0cd5ca911c428e08dbb06e37a8c5 (patch)
tree2782d3dc9d03d9162397a50b3e81e239ffdfe908
parent6e174c4edd4786d93c1e424c45052f70b2bb3fb0 (diff)
downloadguix-304c6b395cdf0cd5ca911c428e08dbb06e37a8c5.tar.gz
gnu: Add python-shtab.
* gnu/packages/python-xyz.scm (python-shtab): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d70d8cc270..03b157de5c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29475,3 +29475,37 @@ writing STL files.  It supports both the text and binary forms of STL.")
 database from the asyncio (PEP-3156/tulip) framework.  It wraps
 asynchronous features of the Psycopg database driver.")
     (license license:bsd-3)))
+
+(define-public python-shtab
+  (package
+    (name "python-shtab")
+    (version "1.5.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "shtab" version))
+        (sha256
+          (base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
+    (build-system python-build-system)
+    (native-inputs
+      (list bash
+            python-pytest
+            python-pytest-cov
+            python-pytest-timeout
+            python-setuptools-scm
+            python-wheel))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace
+             'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest")))))))
+    (home-page "https://github.com/iterative/shtab")
+    (synopsis "Automagic shell tab completion for Python CLI applications")
+    (description
+      "This package automatically generates shell tab completion scripts for
+Python CLI apps.")
+    (license license:asl2.0)))