summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:04:03 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:41:46 -0400
commit3918ed732eabb2fb9968552416009cbed47f8055 (patch)
treeaab5f0410f3f2e91c101ca1be3d7f8879847d12a
parent114ef0a4c5e1629c39ce1a8fcc281257e549cedd (diff)
downloadguix-3918ed732eabb2fb9968552416009cbed47f8055.tar.gz
gnu: ffmpeg: Use invoke.
* gnu/packages/video.scm (ffmpeg)[arguments]: Use invoke in the custom
configure phase.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 94e1729403..b9db350826 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -744,13 +744,13 @@ standards (MPEG-2, MPEG-4 ASP/H.263, MPEG-4 AVC/H.264, and VC-1/VMW3).")
                 (("#! /bin/sh") (string-append "#!" (which "sh"))))
               (setenv "SHELL" (which "bash"))
               (setenv "CONFIG_SHELL" (which "bash"))
-              (zero? (apply system*
-                            "./configure"
-                            (string-append "--prefix=" out)
-                            ;; Add $libdir to the RUNPATH of all the binaries.
-                            (string-append "--extra-ldflags=-Wl,-rpath="
-                                           out "/lib")
-                            configure-flags)))))
+              (apply invoke
+                     "./configure"
+                     (string-append "--prefix=" out)
+                     ;; Add $libdir to the RUNPATH of all the binaries.
+                     (string-append "--extra-ldflags=-Wl,-rpath="
+                                    out "/lib")
+                     configure-flags))))
          (add-before
           'check 'set-ld-library-path
           (lambda _